Velbus Network Link - Velserv

Hi everyone,

Actually Openhab and the serial binding are working fine but I would like to run the Velbus Network Bridge. I installed Velserv as well described by Stuart (MDAR) but I’m getting:

When I look at the last lines it says:

/bin/stty: /dev/serial/by-id/usb-Velleman_Projects_VMB1USB_Velbus_USB_interface-if00: No such file or directory
velserv.service: Main process exited, code=exited, status=1/FAILURE

When I look in the directory /dev I can’t find a dir “serial”.

Of coarse when I’m trying to setup the Velbus Network Bridge by means of the Paper UI it gives me:

Something must be wrong but what? Any idea what is causing this problem?

Thanks in advance for your time!!



Hello Jona,
let’s try to help you out. Can you do the following 3 commands for me at the command prompt:
ls /dev/tty*
ls /dev/serial/by-id/
put the output of the command here, this is to see if your vmbusb is correctly named.

greets Jeroen (writer of velserv)

1 Like

Hi Jeroen,

here is the output of the asked commands at the command line:

Thanks for your help. Much appreciated!!

Greetz back,


PS: as I’m trying to install the Velbus Network Link, the Pi isn’t connected with a serial cable to the VMBRSUSB

That’ll be your problem then :slight_smile:

There needs to be a physical connection to the Velbus network / USB port somewhere.

Do you just want to create a network bridge in openHAB2 so that you can also access the Velbus Network over IP from VelbusLink at the same time?

In which case…

[Remember to delete the Serial Bridge in openHAB2 before doing the following, else OH will lock onto the Velbus USB device]

Connect the USB device to the Raspberry Pi (assuming openHAB2 is running on the Pi)

Configure VelServ to use that device.

Configure openHAB2 Velbus bridge to connect to
Port 6000 

Then you can access the VelServ server from anywhere else on your local network by using

Port 6000

Or do you have another use case in mind?

1 Like

As Stuart directed: the VMBRSUSB has to be physicaly connected to your PI or the velserv program can’t find it to make a connection and stops. Is there are reasons to have only the server running without the gateway, you’ll need to adjust some things. But I think you don’t need this because this is only usefull when you have another velserv running and want to make a bridge over the network etc (complex things :slight_smile: ).


Hey guys,

Just retried the Network binding with the cable on this time and everything is working great even connection through the Velbuslink is working great. Of coarse it needed a physical connection. Sorry for that…
Another question about the time and date syncing. This normally is also done by the Velserv isn’t it? Is there a time interval that can be set or is this done at a certain time?

Up to Openhab now…

Thank you guys!! You made my day!! :wink:



1 Like

Hey Jona

Thanks to @jeroends fabulous efforts, it really is that easy :slight_smile:

Time updates isn’t done within VelServ, it’s handled by the openHAB2 bridges. (or OpenRemote / HomeAssistant etc)

If you open the bridge in PaperUI, you’ll see a “Show More” section.

In there is the time update interval.

That said, Jeroen has created a standalone VelTimer app if you want a separate Velbus system time update.

Useful links for anyone finding this thread in the future

VelServ How-to on this forum

Velbus own Snap TCP package

Did find the time interval setting back in the OH 2.x binding :wink:

Stuart and Jeroen, thanks for your wonderful assistance and patience!!!

Have a nice eve,


1 Like