Velserver: welke modules moet je installeren

Misschien moet ik ook vertellen dat ik vanaf de etcher build voor openhab ben gestart.
En daarbovenop heb ik nog onderstaande modules geinstalleerd.

apt-get install automake
apt-get install nodejs
apt-get install libboost-all-dev
apt-get install libev-dev
apt-get install libhash-merge-perl
apt-get install libconvert-color-perl
apt-get install libdbi-perl
apt-get install libcommon-sense-perl

Lees eens door deze How-To : Install and Run VelServ - a Velbus TCP Gateway
Mdar heeft hier een mooi script voor geschreven.
Staat ergens in de treat vermeld hoe.

2 Likes

@Bert_E
Bedankt voor je lieve woorden.

Dit is de link naar het script

Hier is een link voor de nieuwste ontwikkelingsversie van de binding

1 Like

Supercool, ik begin hiermee en laat het weten als ik nog problemen heb.

1 Like

Bij het doorlezen van de documentatie zie ik dat je nu rechtstreeks in openhab de velbus binding kan installeren. Wil dit dan zeggen dat we velserver niet meer moeten installeren?

VelServer & Python-oplossing van @Stef_Coene dateert van vóór de openHAB2-binding van Cédric.

Terwijl de VelServ TCP gateway van @Jeroends een zeer robuuste manier is om uw Velbus USB-verbinding bloot te stellen aan veel softwareoplossingen, zoals openHAB2, OpenRemote, HomeAssistant & VelbusLink

VelServer biedt functionaliteit die de binding van Cédric (nog) niet heeft, dus u moet het pad kiezen dat u wilt nemen.

Je zou een combinatie van beide kunnen gebruiken, net als de schoonheid van openHAB2.


Original English, before Google translate

Stef_Coene’s VelServer & Python solution predates Cédric’s openHAB2 binding.

Whereas Jeroends’ VelServ TCP gateway is a very robust way of exposing your Velbus USB connection to lots of software solutions, like openHAB2, OpenRemote, HomeAssistant & VelbusLink

VelServer offers functionality that Cédric’s binding doesn’t have (yet), so you must decide the path you want to take.

You could use a mixture of both, as is the beauty of openHAB2.

We geraken steeds verder :slight_smile:

Velserver is geinstalleerd en running.
Ik kan connecteren met de velbusapp op poort 6000
Maar als ik scan dan gebeurt er niets.

Ik zag ergens in een post dat je kan loggen via ./velserv -d … -p 6000 -vvvvvv
Maar hier krijg ik niets te zien.

Enige tips?

Sorry ik zie dit in die log

Velserv: socket is OK…
Velserv: setting socket options is OK …
Velserv: error binding the server!

@kasaert velserv bestaat inwendig uit 2 programma’s. het eerste is de server, deze zorgt voor de distributie van al de berichten, het tweede is de client (gateway), deze zorgt voor de verbinding tussen velbus en de server.
Bij jou lijkt de server niet zijn “ding” te willen doen. Kan je de volledige commandoregel eens posten alsook met welke user je dit wil doen. Het laatste is vooral belangrijk want het zou kunnen zijn dat jij als gebruiken van jouw systeem niet de correcte rechten hebt om een server te creëren. Probeer eventueel met sudo het programma te starten.

Ah godverdikke toch, ben geen linux expert maar ik had sudo -su gedaan voor ik startte en ik dacht dat dan alles kon gestart worden.

Nu heb ik onderstaande uitgevoerd en dan wacht hij wel, maar als ik connecteer komt er niets in en als ik dan erachter scan dan komt er ook niets in.

sudo ./velserv -d /dev/serial/by-id/usb-FTDI_TTL232R-3V3_FTF5T5OM-if00-port0 -p 6000 -vvvvvv

Wat is dit?

Het is niet het Velbus USB-apparaat.

What is this?

It’s not the Velbus USB device ?

Het is een device met dezelfde functie. Op mijn andere pi werkt het met de oude velserver logger en Velbus.

1 Like

Wat gebeurt er als u het bestand velserv.service bewerkt om dit apparaat te adresseren?

Som jeg har gjort i denne specielle versioner for dig

wget http://www.mdar.co.uk/dl/velserv-setup-kasaert.sh
sudo sh velserv-setup-kasaert.sh

What happens if you edit the velserv.service file to address this device?

Like I have done in this special versions for you

wget http://www.mdar.co.uk/dl/velserv-setup-kasaert.sh
sudo sh velserv-setup-kasaert.sh

Ik had die file al aangepast :sunglasses:

Maar ik heb juist nog eens mijn oude pi eraan gehangen en nu kan ik ook niet meer connecteren. Ik zal dus in de loop van de dag eerst eens mijn bus resetten.

Ik hou je op de hoogte. Alvast al een heel dikke dank je wel voor al jullie antwoorden :blush:

1 Like

Ik denk dat je mijn ondersteuningskennis van niveau 1 nu hebt uitgeput. :cry:

Het is over naar @jeroends voor wijsheid op expertniveau.

Succes


I think you’ve exhausted my level 1 support knowledge now.

It’s over to Jeroends for some expert level wisdom.

Good luck

Toch bedankt voor de hulp :slight_smile:

Ik krijg nu zelfs die debug niet meer in listening mode.

sudo ./velserv -d /dev/serial/by-id/usb-FTDI_TTL232R-3V3_FTF5T5OM-if00-port0 -p 6000 -vvvvvv
Device : /dev/serial/by-id/usb-FTDI_TTL232R-3V3_FTF5T5OM-if00-port0
IP address : 127.0.0.1
Port : 6000
Verbose level : 6
Client mode : 1
Server mode : 1
/bin/stty: /dev/serial/by-id/usb-FTDI_TTL232R-3V3_FTF5T5OM-if00-port0: unable to perform all requested operations
Velserv: socket is OK…
Velserv: setting socket options is OK …
Velserv: error binding the server!

Voor je usb device, je kan zorgen dat dit onder een gemakkelijkere naam te vinden valt.
Met lsusb kan je zien welke usb devices er zijn.
Bij mij geeft dit onder andere:
Bus 001 Device 005: ID 10cf:0b1b Velleman Components, Inc.

Voor een handigere naam heb ik file /etc/udev/rules.d/99-usb-serial.rules met daarin:
SUBSYSTEM==“tty”, ATTRS{idVendor}==“10cf”, ATTRS{idProduct}==“0b1b”, SYMLINK+=“ttyVelbus”

Het handig is dat je dan een /dev/ttyVelbus hebt. Wel eerst rebooten of je USB kabel eens uit en terug in steken.

En bij mij draait velserver dan gewoon als
velserv /dev/ttyVelbus

Stef

Hey Stef, bedankt voor je tip.

Nog even een update, ik heb dan uiteindelijk die debugging mode terug kunnen opstarten maar er komt niets tevoorschijn. Zowel niet bij het connecteren als bij het scannen.

@kasaert hoe is jouw hardwarematige setup. Omdat je de FTDI_TTL adapter gebruikt had ik graag geweten hoe jij jouw interface verbindt met je Raspberry. Kan het zijn dat jij een usb naar seriële omvormer gebruikt om dan een seriële interface naar Velbus te gebruiken? Indien dat he tgeval is kan daar misschien wel het probleem zitten gezien de mainstream altijd rechtstreeks de usb naar velbus interface gebruikt. Ik heb zelf al problemen ondervonden met een usb naar seriële interface om dan de VMBRSUSB via de klemmen (serieel dus) aan te sturen. Omdat ik toen de tijd niet had heb ik deze toch maar via USB aangesloten en er verder geen aandacht mee aan besteed. Misschien dat ik dit toch eens terug moet proberen om te zien waar daar de fout zat.

1 Like

Hey Jeroen,

Inderdaad wat je zegt klopt.