Dead VMB4PD?


I’ve got an VMB4PD that worked ok for a couple of days until recently it is locked on the display menu.
Display always shows the backlight/contrast menu, buttons don’t work, it shows up in Velbuslink but when I try to configure it Velbuslink crashes after +/-40% while reading the memory blocks.

I tried to powercycle it many times, disconnected it for a day, still to no avail. It keeps comming up with the display settings…

Any way to shock the thing back to life?

Thanks in advance.


Maybe the config button is always pressed. Disconnect the power supply and check the button with a multimeter in continuity test.
Another possibility, there is an infrared light source which disturbes the remote receiver. Use some black tape to hide the receiver module on top of the display.
If these tests fails there may be a hardware problem with the module.

Tested the config button already, and i tried the unit in diferent places (install location, lab) and other modules in the vicinity work as intended, so I doubt it’s IR polution.

Any other ideas? I’ll order a replacement in the meantime, but it would be a pitty to have to throw a unit away.
Is there a way to reflash the firmware?

We’d suggest you return the module for inspection/repair.