Not all messages being passed over RS232 interface?


I have just received a few modules of yours:
4-way relay (given address 18)
1-way dimmer (given address 16)
8-way pushbutton module (12)
and your RS232 interface.

I have connected the modules with the correct termination (the jumper set at each end of the link. This happens to be the RS232 interface and the dimmer module)

I can program the relay module to respond to a pushbutton reliably and correctly and every time data should go over the bus the LEDs light up on each of the modules including the RS232 interface.

However, the traffic log in VelbusLink does not show all packets which I know are going on the bus. For instance, if I toggle one of the relays in the relay module four times (eight presses), I might get two “turn on” events and one “turn off”. Or, as I have the log in front of me, pressing one of the buttons on the pushbuttoon module shows

and is clearly missing some of the events (how else would two released events be one after the other).

Is this an error (in which case, where should I start troubleshooting) or expected behaviour?
Many thanks,

Maybe there is an error on the bus. One of the modules receives the message incorrect and ask the sender to resend it. This can be the reason why there are two released messages are shown.
Check if there is only one terminator placed.
Check if the bus is correct connected to each module (polarity low & high).
Try only the push button module together with the serial interface module for correct events.

Hello, thanks for your reply.

I have checked bus polarity is correct. Termination was originally present at each end of the bus and gave the results described above.

This morning I tried terminating all the devices on the bus, and now many more messages are being seen by the RS232 interface. It’s still not perfect though. Sometimes after I send an “all relays on” or “all relays off” command to the relay pack I will get four messages, one each describing the status of each relay. Other times I get a different number … two or three but not always for the same two or three relays!

I am using CAT5 cable between the devices - currently very short as I’m testing the modules (unsuccessfully so far :frowning: ). I will try only connecting one module later today.

Any other thoughts in the meantime?

OK, well I’ve now run some more experiments - numbers 1 and 2.

In experiment 1, I had simply the RS232 interface and the 8-way switch module attached. Both had their termination jumpers set, although I tried also taking the jumper in the switch module off - still erratic.

Once this was setup, I regularly pressed button 1. Sometimes I held it long enough for the “long press” message to be sent, other times I released it before then.

The screenshot …
Shows that the messages arrive in a nonsensical order (because many are missing). With every message sent on the bus, the LEDs on the serial interface blink showing that there is electrical connectivity.

In experiment 2 I connected only the dimmer. I operated the dimmer with the manual, built-in, switch. The dimmer is tied to one of the switches and so is sending messages to the switch to update its LED. You will see, again, that not all messages are being received by the PC. To verify that all the LED messages were going properly onto the bus, I then reconnected the switch module: the LED on switch 1 then always lit / blinked as intended.

Please can anyone offer advice? I’m running out of ideas (and patience!)

Many thanks,

At this time, we are unable to simulate the problem you experience. We suspect either the PC serial interface or the Velbus serial interface module. Please try the units on a different PC. If you get the same result, we suggest to exchange your serial inteface module.