Openhabian boot problem on RPi2 Model B V1.1

Hi guys

My RPi2 with openhabian doens’t boot anymore. (I already ordered a RPi 4 but I hate to lose everything (things, rules, persisence,…), I would like to install the RPi 4 at my pace, not hurry-hurry because “it doesn’t work anymore”)
Anyway, I get this error:

—[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)

After a Google search I tried to change cmdline.txt on a Windows machine (I ignored the Windows prompts to format the SD), I changed “root=PARTUUID=c6bc21bc-02” to 06, then booted the RPi again.
So then the RPi hangs on

random: crng init done

Another Google search tells me this:

At boot, the kernel waits for mouse movements to initialize the random number generator.

So I plug in a mouse, a new USB device number 5 gets installed (using USB HID v1.10 Mouse (SIGMACHIP Usb Mouse)), but then it disconnects (I didn’t pull it out), then a new USB device number 6 gets installed, then disconnects again, then number 7, and so on, and so on.
So I was thinking maybe it’s the mouse.
I pull out the mouse, plug in another one (USB HID v1.11 Mouse (PixArt USB Optical Mouse) but then the screen hangs again.

So I pull the power, plug it back in (with the second mouse plugged in an USB port), last thing I see is the mouse being installed, then I get the “random: crng init done”. I try to move the mouse, click buttons, scroll the wheel, nothing happens.

I’m gonna pull the power again, plug in the first mouse, and just leave it like that for a couple of hours, maybe at some point it’ll get past the install/disconnect the mouse.

If there’s any news, I’ll post an update.

Any ideas?


It seems that the mouse only gets disconnected when I move it, USB device number 61 atm…

May I suggest you post this on the openHAB2 site?

Although I would recommend making a backup / zip of these folders, so you can restore them to your next system.




@MDAR I did what you suggested, thanks.

How can I make a backup of mentioned folders? As I don’t have a Linux PC, only Windows…

Oh I see…

You could…
Download a copy of Ubuntu and run it from a USB memory stick, using the “Live Boot” option, rather than install it onto your machine.
(Or you can elect to install Ubuntu alongside Windows and create a Dual Boot machine)

Then you’d have a fully operational Linux environment (all be it a little slow).

From there you can access your PI SD card and zip up the folders in question. (Using an easy desktop file manager, that works just like you’d expect)

You will even be able to save the zip files onto your Windows HDD :slight_smile:

This means that when your Pi4 arrives, you need only to

  • Install VelServ

  • Install openHAB2

  • Stop openHAB2

  • unzip the backup

  • Start openHAB2 and wait a little.

This should restore everything, including your openHAB cloud credentials :slight_smile:

(Or you can just restore the parts / files you want to)

Good luck :slight_smile:

I restored a backup I made in March
I installed Velserv
I rebooted the RPi
(in that order)
my HABpanel is like it was back in March
But nothing works, Paper UI shows:

I tried to add a new Velbus Network Bridge, but when I click the “+” sign, Velbus Network Bridge is not in the list… I suppose I don’t have the bleeding edge version, located ?
I’ll try that :slight_smile:


So far so good(ish) then.

Did you install the Velbus binding from within PaperUI?

Delete it.

Restart openhab2

And run either of these scripts

sudo wget
sudo sh


sudo wget
 sudo sh

You might have the issue that your Velbus Things aren’t using the correct Velbus Network Bridge

Especially if you’ve deleted the one from the backup.

So if you need to create a new Velbus network bridge, don’t forget to go through each Velbus Thing and assign it to the new bridge.

Good luck

Hold on…

Have you added the Serial Binding?

(From PaperUI)

I did not install the Velbus binding from within PaperUI

  • stopped Openhab2
  • put the .jar in the addons folder
  • Started Openhab2

works like it used to !! :heart:
(so I don’t need to add another Velbus Network Bridge, my Velbus Things use the one installed)

Serial binding is not installed

1 Like

Hi Stuart

I finally found a way to retrieve the folders you mentioned with a Windows software, you’ve probably already read it here:

Now I’m wondering, can I just overwrite those folders on my new SD? Will that work?
(would that work with my RPi4? (now it’s a RPi 2B or something) I’m not gonna do that, since I want to do a clean start some day, just wondering)

You think I can do that with WinSCP?

I’ve also posted this question on the Openhab community forum, but I don’t really like the reply I got from mstormi :stuck_out_tongue:
As he suggests to only overwrite the files I actually changed. Problem is, I don’t know exactly which files I have changed, I use for example persistence, no idea where all those files are stored.

Extra problem is: I tried to backup my current setup, but for some reason the RPi can’t finish the backup

If I could backup my current setup, I would just try, as I can just roll back if it doesn’t work.


It looks like you need to resolve why the Pi can’t create the ZIP file in the backup folder before you go any further.

Without a snapshot of a good working system, you’ve nothing to roll back.

When you are happy that you can backup (and restore) with the openhab-cli backup / restore commands, then look at using WinSCP to access the machine so that you can copy configuration files in small batches to see which works.

In essence this is what Markus is suggesting, but his German to English isn’t great, so he can come across as a little blunt.

To add a few words to his advice…

What he is suggesting is that you open the files from your old SD card in a text editor, ONLY to confirm that the contents have not been corrupted.

Then you can choose to just copy the file to your new SD Card, or cut and paste the text into the file on the new SD Card (or via the SSH / WinSCP session to your live system)

Does that make a little more sense?

In an extreme situation, you could stop openhab2

drop all the folder & contents from the old SD onto your new machine and restart openhab2.

It might work perfectly, or it might object if there is an error in the file/s.

Whatever you do, as long as you have a good backup, you should be able to recover.

As for the persistence, I don’t know where the database files are stored, but in theory you can drag and drop the file when you find it???

The question is, do you need the data from weeks ago? Or can you start with a fresh database?

Good luck,


For the persistence, it’s the data from my solar panels, my brother knows a lot about mysql, and I was able to download csv-files with the data, so he’ll make something to add that data to mysql.
So that’s solved, sort of :smile:

And for everything else, my habpanel is working as it was a couple of months ago.
I do have a “test”-page, or better had… That’s gone, but that’s ok I guess.

I’m just gonna keep it the way it is until I find the time to start over with an all new Velbus-OpenHAB-RPi4.

Thanks for the help!

1 Like