Problem time programing vmb4pd

if i want to time program the vmb4pd whit pc connect whit usb and using velbuslink 5.2.
by klikking on > advanced > timer > setup hef i a error
“access violation at address 00404BD0 in module’velbuslink.exe’. write of adress00547548”

everiting wroks normal accept the time programming and that by al 3 vmb4pd installed on my system

sorry voor het engels


That screen is the form to modify the 20 steps in the 4PD, but it has a problem reading the default values stored in the 4PD.

I solved the problem by setting all programming bytes to 0. At that time I could open the form.

By sending the following 15 lines to the 4PD (low priority, no RTR, datasize 7), the area 0x00C0 to 0x00FB will be cleared. At that time, the screen will work.

CA 00 C0 00 00 00 00
CA 00 C4 00 00 00 00
CA 00 C8 00 00 00 00
CA 00 CC 00 00 00 00

CA 00 D0 00 00 00 00
CA 00 D4 00 00 00 00
CA 00 D8 00 00 00 00
CA 00 DC 00 00 00 00

CA 00 E0 00 00 00 00
CA 00 E4 00 00 00 00
CA 00 E8 00 00 00 00
CA 00 EC 00 00 00 00

CA 00 F0 00 00 00 00
CA 00 F4 00 00 00 00
CA 00 F8 00 00 00 00


Alain, you really did a great job finding this error! Your solution indeed solved the memory error. How did you found the answer? Reverse engeneering using the backup data files? :wink:

thanks a lot!

Hi Gert,

Actually, I found it by accident :slight_smile: I’m writing a C# .Net object wrapper arround the VelBus protocol and while experimenting with my class library I found the solution.

thank you for helping me out.
Now I can get in the submenu ’ time-setup.’
When you enter a time-program in the VMB 4Pd, it 's accepted, but not executed and after this, again you can’t enter the submenu. So it seems that it blocks itself, or could I have done something wrong?
thank you already for the given help.

Thanks for reporting this problem, I will be looking into it rightaway. You can expect a rewrite/remake of the timer configuration dialog.

Apparently the bug is caused by pressing the apply button outside the timer configuration screen. It should not be visible there since there is nothing to be applied and thus garbage might slip into the module’s memory.

Once garbage got into the module’s memory, the pc software will not be able to handle it and it will crash.

This is fixed in the next release.

is there a new release yet?

The latest release (5.7) solves this problem.