RS232 connection


I’m new in this Velbus system. doing some tests now before installing the whole thing I would like to ask if it is possible to connect to the RS232 module via an Ethernet/RS232 converter. I’ve tried this and untill now it won’t work. My TCP connection to the CSE-H53 (ethernet/RS232 convertor) is working wel, the connection of the RS232 to teh velvus module is also OK. When i want to write/read the modules i see the four leds on the RS232 module are blinking but the software gives me a ‘time-out’. When i adjust the clock that is working well !!

Thks for anything that may help


this won’t work indeed (I also tried it a few years ago). The solution I use is using a small pc with my soft on it. This way you could connect velbus thrue ethernet.
I use it for a few years now but since a few days I’m using a new piece of hardware: an olinuxiuno. This is a small embedded pc for only a few euro’s. Seem until now that it does the job very well :-). Maybe it could be a solution for u.

OK thks for your advice, i will look for this olinuxiuno and try this. why couldn’t it work with a convertor ? this converts and sends the IP data directly to the RS232 port … ? My connection works : for example when I do an update of the clock then the clock on the system is changed to the PC time, so sending is OK. Couldn’t it be that the problem is related to the RTS/CTS, DTR/DSR signals, couldn’t this work with a loopback on this signals and only transfer the data ?

I suppose the reason is that a convertor doesn’t give you a nicely formed input at the velbus interface. That’s why I cut the packets into pieces and deliver them.


I got my convertor working. Now I have access to my velbussystem connected to my router on IP (with the RS232/Ethernet conertor) from within my LAN. It still doesn’t want to work trough the internet but I have to check my settings in the modem/router (port forwarding is not working i think). Wat I did to get the conertor working : I changed the straight RS232 cable (pin 1 … 9 where straight connected). now i have pin 2 (rxd),3(txd),5(ground),7(RTS),8(CTS) connected straight trough and the pin’s 1(DCD),4(DTR),6(DSR) are looped back to the convertor and to the RS232 velbus module. This works perfect. When I make the connection in the Velbuslink (V8.5.10) (TCP/IP connection) I have immediate connection and everything works fine, Also wireless working is no problem.

Now still trying to connect trough the net … hope this can help you

Did you also tried to create a lot of data? For example, reading out the whole bus (backup) and restore the bus? I know I had problems with that, just writing a light on/off command on the bus was no problem, but bulk data was totally messed up.

Until now i have only 4 modules (VMB4RYNO/VMBDMI/VMB8PDU/VMB4PD). When I start whith an empty project, reading of the modules is no problem, then I made a lot of connections, suppressings, etc… on all the pushbuttons and all the relais (including dimmers and virtual relais). Sending this configuration, everything works. Then I started again with an empty project, scanned the system and reading all the settings and everything was as i programmed it.
Of course this is only with four modules and maybe it won’t work anymore when I install a whole system ! As it is foreseen for installation in december/januari I can test this before this date… hopely it will work also. Keep you informed later on.
Thanks anyway for the info and for now, I wish you a nice holiday if it is coming up for you.