Signum / Raspberry pi 3 / Home assistant


Ik ben wat aan het experimenteren met Home Assistant en gebruik hiervoor een Raspberry pi 3b+.
Mijn SMA omvormer, Nibe warmtepomp, sonos, tv, etc. zijn probleemloos al geïntegreerd. Al dan niet door de modbus in te schakelen.

Ik wil graag de Velbusintegratie toevoegen aan HA, maar lijkt me niet te lukken.
Heb nochtans alle stappen overlopen volgens zoals hieronder beschreven:

De VMBSIG heb ik via een usb kabel verbonden met mijn RB.
Heb in HA alle mogelijke verbindingsreeksen al geprobeerd, waaronder:

  • /dev/ttyACM0
  • /dev/ttyUSB0 (met variaties in /dev/ttyUSB1,2,3, enz…)

Enkel via ’ /dev/ttyAMA0’ kon ik schijnbaar de velbus integratie toevoegen.
Echter geen apparaten of entiteiten zichtbaar.

Hulp gevraagd :slight_smile:


Have you tried to via TCP ?


Thanks for the reply.

I did use " " allready. (as indicated in the HA instructions)
However, not sure if that is correct?

My signum IP is, So i tried and was once again able to integrate velbus. But again no devices or entities visible.

Am i missing something?

You’re nearly there

Within Signum, what are the TCP connection details for Velbuslink?

Use those within your HA configuration and you should be up and running.

Is this correct?

Be aware that those instructions assume that the Velbus-TCP or VelServ application are running on the same machine as your HA instance.

In this situation, you want to access your Velbus network via the TCP gateway within Signum, across your LAN.

Do you have the original Signum?

Did you know you can apply for an transfer to their (limited) HA version.

However, you’re probably better off staying on the road you’re already on.

Any clue how to find that?
I looked into signum config, but didnt find anything.
I also looked into velbuslink, same result.

Many thanks for the help.

You should be able to find it via the web interface on your Signum.

It’ll be in a different place, depending on which firmware you have.

Try looking in the “settings” or “Network access” section? (Purely a guess)

(Mine isn’t powered up right now, as it’s in a demo case, ready for taking to a college on Monday)

1 Like

in velbuslink you can discover the signum, it will shw you the ip address:

in hass you should use:


1 Like

Hi everyone,

The trick that did it:

In signum i was able to enable tls/ssl and now i can see my first devices and entities.

Thanks for the help, leared a lot!

1 Like

Oh… very tidy!

What cabinet is that? Did they come with DIN rail already fitted and slotted trunking or did you make those yourself?

How did you do those neat printed cable labels?

  • Andy
1 Like

Thanks Andy.

Those beauties are from Future Automation, all ready to go with rails and containment.

FA also offer a full Pre-Assemble, Wire & Testing service.
Tell them what Velbus hardware you want in the cabinet and it gets shipped to site, ready to be hung on the wall and terminated.

I can even pre-program the Velbus hardware if needed…

Just a little to late for you project… Unless … :articulated_lorry: You’re on the move again?

Oh yeah, I do like those too.

They get a bit messy when there are loads of them, but they are rather nice.

Battery powered, Bluetooth label printer

The one I have can use multiple label widths

Or there is the slim label only version

With a wonderful selection of labels

Watch out for the deals !

I always buy WAY TOO MANY :laughing: