Sunrise/Sunset programsteps not working after summertime


#1

VMBGPPOD firmware 1720
Time changed to summertime last night. Now Sunrise/Sunset based program steps stopped working.
VelbusLink 9.84.0.3 is showing correct sunrise and sunset times.
Summertime is not taken into account. Sunset +30’ (19h03 + 30’ = 19h33) is executed at 20h33.


#2

Silly question…

Has the Velbus system time been updated?

Reason I ask is because all my sunset stuff seems to be okay.


#3

Hi,

Sure, first thing I checked.

Meanwhile, I uploaded the module from VelbusLink.

I’ll see in the morning…


#4

Still not working. Checked Home Center to see if Time sync was set correctly and Daylight saving time was activated.

Any suggestions?


#5

Is this on only one module, or on various?
What exactly have you observed that makes you say the program steps stopped working (eg. blinds didn’t go up, …)?
Has this happened only one morning, or various mornings in a row (today also)?
What do the icons next to the module indicate in VelbusLink? If you can, please post a screenshot of the module with the channels visible, together with the icons next to the module and channels.
If possible, leave a PC on overnight, with VelbusLink running and connected, save the logging in the morning and post it here. The Velbuslink project file (.vlp) might also be helpful (if you prefer, send it by PM).


#6

I sent you a PM with the log and the project file.


#7

Same problem occured again on Monday 25/03/2019. This is the first day of the week of the summertime change.
Velbuslink 10.0.2 is showing correct sunrise and sunset times, but actions based on these stopped working.
I wrote my own logger so complete daily logs are available.


#8

In the latest versions of VelbusLink you can right-click on a module and request the time and date.
Could you post here the following please:

  1. time and date of the module that has the program steps
  2. the “real” time and date on that moment
  3. a screenshot of the sunrise/sunset table of the same module
  4. the moment when the program steps are executed (assuming they are executed but at a different time than what you expect)

#9
  1. 14h49
  2. 14h49
    4. 27/03/2019 20h21 iof sunset (19h06) + 15’ = 19h21

#10

Could you check the date also on the module please (question #1)?

So the program step is executed 1 hour too late, correct?


#11

I’m having the same issue… Sunset steps are not working anymore…

I updated all the modules firmware to the latest version(1845) and it is still not working… I think the problem started when I installed the latest velbuslink version…


#12

Are they not working at all, or at the wrong time? (eg. one hour too late, as with wvs)


#13

They are not working at all…
image
As you can see they should be enabled and active…
I also requested the time of the module and this is correct…
image


#14

And what firmware do these modules have? If it’s not the newest version, upgrade the FW please.


#15

Is it only the sunset program steps that are not working, or all program steps?


#16

Date AND time of module are correct.
Firmware 1822. Upgraded to 1845, same result.
Sunset/sunrise related steps execute at wrong time, other program steps are working.


#17

I just noticed something in your VelbusLink project you sent me last year: you use the actions 106 (up) and 110 (down) for program steps. This is not ideal, since these actions can be interrupted.
It’s better to use actions 109 (immediately up) and 113 (immediately down).
It may not be directly related, but could you change this please, just to make sure?
Also, do a sync > write on the blind modules and the input modules that contain the programs, and uncheck the “only write modifications” in the Sync dialog, just to make sure there’s no residual error left in the memory maps.

We cannot reproduce the problem here, so it’s difficult to tell what exactly is happening.


#18

Ok, I’ll change that and give you feedback.

I can confirm you that a friend of mine has the exact same problem with his installation.


#19

Since the summertime change, the program steps are executed on the correct time again.


#20

OK, thanks for the info.
We’ll set up a test environment and see if there’s a way to reproduce this behavior. If we find anything out I’ll post it here.