USB Port : be carefull on which USB port you connect

I just tried on Windows 7 and it works with Velbuslink ONE time. Then when you close the application and restart velbuslinks, The software hangs after the selection of the COM port popup. You have to change the usb wire to another port, restart application and then it works again.

Then tried it in c# and its doing the same. The exception thrown is: IOException
“A device attached to the system is not functioning”
at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.InternalResources.WinIOError()
at System.IO.Ports.SerialStream.InitializeDCB(Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Boolean discardNull)
at System.IO.Ports.SerialStream…ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
at System.IO.Ports.SerialPort.Open()

After doing some research further:

  • I always connected the velbus through my Usb on the screen (there are 2 USB ports on my computerscreen)
  • then changed it and connected it directly on the motherboard USB connector, and it works well…

So, don’t know how to interpret this bug, but hope can help some people out there
tested on : windows 7 64bit



Have you checked if there’s an extra velbuslink.exe *32 process running at the time of the error.
I found that sometimes when you close Velbuslink the windows closes but the process keeps running and locks the serial port.

Maybe the time is come to release the long awaited Velbuslink 6 … Hint hint

Best regards


edit: FYI I use Velbuslink on Win 7 x64

I have the same problem on win7 64bit :frowning:

All works fine when my VMB1USB is connected for the first time on a certain usb port.
But when I restart the pc, the usb driver tries to reinstall and fails.

I am always running as an administrator (at install time and later on).

Any clue?

Did you install the driver successfully the first time?

Do you always plug it into the same port to plug your device into? Installing the driver for one port does not mean it’s installed for another port. It may seem strange, but that’s how it works in Windows :unamused:

I’ll do some tests under Windows 7 32/64 bit to see if everything works as it should. The driver we supply was meant for NT/XP but i don’t think there should be problems.

I’m having a similar problem with Win7 in that if I boot up then plug my VMB1USB into (the same) port, it will install the velleman driver ok, will show up, in my case as com3, and apparently discovered by velbuslink7 (I have only VMB8PB) connected to it. I have not yet gotten either Hyperterminal or my VisualBasic program to connect to iVMB8PB. If I were to reboot, leaving the VMB1USB plugged in, I would then find it being disabled by Win7 as an USB HUB that threw an exception. It would no longer show under a COM port.

Any suggestions?

Do I have this right?:

  1. You connect the VMB1USB on a free USB port on your computer
  2. Windows detects the new hardware and installs the correct driver
  3. The VMB1USB is installed as COM3
  4. You open VelbusLink 7 and it finds the VMB1USB you just installed
  5. You connect to the VMB1USB inside VelbusLink 7
  6. ? You perform a scan inside VelbusLink 7 and it does not find your VMB8PB
  7. ? You shut down your computer and reboot
  8. ? The VMB1USB is no longer installed correctly