Velbus on home assistant installation

hello, to start, sorry for my english. I speak french.
I have an elbus installation running under openhab 3 in usb on rapsberry pi 4.
I want to try home assistant under docker. unfortunately I’m already stuck in the installation phase.
I don’t understand what I need to put.
thank you in advance for your help.
Capture d’écran 2022-09-12 225820

1 Like

I’m not a HomeAssistant expert

But my guess would be “the path to your Velbus connection”

Are you accessing via a gateway or directly to the USB?

(Are you continuing to run openHAB?)

My advice would be to run a TCP gateway like VelServ or Velbus-tcp first.

That way you can run openHAB and HomeAssistant at the same time.

If you are running a gateway, you just need to enter the address

127.0.0.1:6000

Or directly, it might be /dev/ttyACM0 or /dev/ttyUSB0

And give it a meaningful name in the top part.

Try reading this thread or posting a question in there.

Bon chance,

Stuart

hi,

It depends a bit on the connection itself… if you use the velbus server, you want to disable TLS (encryption) on your Velbus server (I could not get it working with TLS at all)… after that you can just put in the IP address and port: 127.0.0.1:3678

if you are using the direct USB cable into your RPi you can put the direct path to the usb: dev/ttyUSB00

if you don’t know the USB path - you can also just perform an ls /dev to see which ttyUSBxx’s are available…

while all the output modules are listed in home assistant (switches with names etc) - the input modules (the buttons you press) are not available in home assistant (contrary to openhab) - if you have full automations behind your buttons - you’d need to recreate them in home assistant

hello, so I am connected in usb (VMBRSUSB)
I no longer have openhab running since I installed it on another pi 4 and another sd card. I have this error in photo even when changing the ports.


Can I humbly suggest that you post this question on the HomeAssistant forum?

As this is a specific issue with HomeAssistant, rather than the Velbus hardware.

No doubt the Velbus developer for HomeAssistant will be happy to help you.

One thing I did read is that sometimes a reboot after entering the port can put things straight.

@cereal
Can you help?

see if its actually being detected…
List USB Devices Linux (linuxhint.com)

and did you check that nothing else is using that port… (such as velbus-server)

thank you, I will probably look on the side of the home assistant forum. even if for lack of time I had to put all that aside, unfortunately. anyway thanks again for the help.

I don’t have velbus server. nothing is plugged into the usb port, I tried several ports.
but I don’t understand that my velbus installation needs to be connected to the raspberry pi during installation. we can’t install it and plug it in afterwards? like for openhab?
but as soon as I find the time I reconnect the rapsberry pi and check if the ports are free

That’s odd.

Unless you have a very old RS232 interface, I can’t think of how you’re going to achieve this.

The quickest option is probably too buy and install a USB module.
At least that way you’ll know where it is and how it’s connected.

(Doesn’t matter if there is one on the bus already, you can have multiples)