Velbus with Openremote on Synology NAS


#1

Is it possible to run a JVelbusD, VelServ or equivalent Velbus link on a Synology NAS ?
I’ve already installed the Openremote on my Synology but am missing the link to the Velbus system.

My Velbus system has a Homeserver (VMBHIS) running which is connected to my home IP network on which also the NAS runs.

I would like to avoid an extra component like a RaspberryPI.

Any other solution without extra hardware is also welcome, like using the VMBHIS with additional software (but keeping also Homecentre).

Many thanks.
Bert.


#2

Hi

My short answer is that I don’t have any experience with Synology.

However…

As OpenRemote is a Java application and you’ve got that running… Getting JVelbusD running with the same Java runtime should just be a matter of ensuring RXTXlib is in the right place, as per the instructions on the OpenRemote GitHub documents​ page -

In the same vein, I’m fairly sure that VelServ would work too if your ​NAS is Linux based.

Obviously you will need another Velbus to USB adapter - VMBRSUSB or VMB1USB.

You might find that you get more OpenRemote support on the Google Groups site :-
https://groups.google.com/forum/m/#!forum/openremotecommunity


#3

Hello

How did you get on?

Best wishes,

Stuart


#4

Stuart,

Thanks for following up.
Unfortunatly I had (and have) no time to work on this at the moment.
Hope to spend time on it again after summer time.

Regards,
Bert.


#5

Hi Bert,

Thanks for the update.

Sorry you’re day job is keeping you away from your home.

Don’t they know you have far more important things to be doing :wink:

Good luck finding your work / life balance again.

Keep smiling :slight_smile:

Cheers,

Stuart


#6

Bert, we run Velbus and Synology already for many years. What do you want to do ?
Synology’s nas function is one thing, if you want to get into the applications, then it’s another thing, as well as interfacing with the linux os, which I would discourage for security reasons.


#7

Hi Stuart,

I’m picking this up again and switched to using a Raspberry PI.
I installed JVelbusD following your instructions on the Github pages and I think it went well.
But when getting in Openremote to start picking up the Velbus I/O, it seems I’ve no connection…
Is there a way to check if the connection Velbus - USB - IP through the JVelbusD is working and has connection ? Like you wouls measure with a Fluke in your electrical circuits to find the bug :slight_smile:

Thanks already !


#8

Hi

I’m glad you’ve got some time again.

The easiest way to see if there is a live connection is to use your Raspberry Pi with VelbusLink.

Just connect using a TCP/IP connection and point VelbusLink to the IP & port you’re using. (Normally 6000 for JVelbusD).

That said…

VelServ was created originally for Raspberry Pi and it is actively developed.

You can find lots of references to it on this forum, or you can follow the instructions I’ve put on the OpenRemote Velbus how to page :- https://github.com/openremote/Documentation/wiki/Velbus

It is much easier to setup than JVelbusD. :slight_smile:

Again, to test it, just connect with VelbusLink.

Please let me know how you get on.

Cheers,

Stuart

Edit…

Add the executable bit to the new velserv app by using chmod

chmod +x velserv


#9

Stuart,

I installed the VelServ on my PI an compiled it with GCC. It’s now located on /opt/Velserv
When I type “sudo ./velserv -p 6000” or even “sudo ./opt/Velserv/velserv -p 6000” on the prompt, the task is not found…
Is there any additional help to start Velserv ? Is it possible to start Velserv automatically when the PI starts up ?

I’m quite new to the PI so might be some basis things…

Many thanks for the help.
Bert.


#10

Sometimes you also have to specify the /dev/tty device.
This is normally ttyACM0.
So the command is
velserv -d /dev/ttyACM0

For automatically starting, add it to /etc/rc.local before the ‘exit 0’.
It will place itself in the background so you get your prompt back when you execute velserv.
You can check if it’s running with ‘ps -ef | grep velserv’. It should show you the velserv command.

Stef


#11

Was indeed a simple basic thing. The file velserv as compiled with GCC was not executable yet.
With ‘chmod +x velserv’ it’s solved :slight_smile:

I used ‘sudo ./velserv -d /dev/ttyAMA0 -p 6000’ to start it and checked with Stef’s ‘ps -ef | grep velserv’ and it seems running now.

Next step is the connection to my Velbus system.

Thanks for the helpfull feedback.

Bert


#12

It seems Velserv is running at my PI :
pi@raspberrypi:~ $ ps -ef | grep velserv
root 961 1 99 13:05 ? 00:03:54 ./velserv -d /dev/ttyAMA0 -p 6000
pi 984 975 0 13:09 pts/0 00:00:00 grep --color=auto velserv

But when I try to connect with VelbusLink on my PC (with IP adress from the PI and port 6000), scanning of my modules goes very fast and no modules are recognized when I start from my existing project.
Also tried to create a new project from scratch with downloading modules through the Velserv connection. This results in an empty project.

Any idea’s what goes wrong ?


#13

Hi

At first guess…

I’d suggest that your VMBRSUSB or VMB1USB doesn’t have a connection to your Velbus network…

I think I’m right in saying that VelServ won’t start if it can’t confirm a connection to a VMBRSUSB or VMB1USB.

Or…

Have you disconnected the usb lead without restarting VevServ or the Pi?

I have had a situation with a VMB1USB which gave similar conditions, power cycling VMB1USB cured it, for a few months.

(I simply removed the +12v from the module)

I’m happy to try to re-create your situation if you can perform a power cycle and report the exact steps and conditions.

FYI, I’d be doing it with BeagleBones or Samsung Netbooks (both running Ubuntu)

Good luck,

Stuart


#14

Hi Stuart,

Tested the following situations :
A. Start with powered up PI

  1. Power up PI
  2. Start Velserv with sudo ./velserv -d /dev/ttyAMA0 -p 6000
  3. Unplug USB cable from Homecenter
  4. Plug USB cable in PI
  5. Start Velbuslink on my PC and try to connect to PI IP adress and port 6000
  6. Scan the bus - short scan (screen flashes shortly) and nothing found

Reconnected USB to Homecenter and connection works through Homecenter

B**. Start from not powered PI**

  1. Disconnected USB cable from running Homecenter
  2. Connect USB cable to PI
  3. Power up PI
  4. Start Velserv with sudo ./velserv -d /dev/ttyAMA0 -p 6000
  5. Start Velbuslink on my PC and try to connect to PI IP adress and port 6000
  6. Scan the bus - short scan (screen flashes shortly) and nothing found

C. Start from not powered PI and not powered VMBRSUSB

  1. Disconnected power from VMBRSUSB
  2. Connect USB cable to PI
  3. Power up USB and power up PI
  4. Start Velserv with sudo ./velserv -d /dev/ttyAMA0 -p 6000
  5. Start Velbuslink on my PC and try to connect to PI IP adress and port 6000
  6. Scan the bus - short scan (screen flashes shortly) and nothing found

Reconnected the USB to Homecenter and connection is OK

Is there any way to check on the PI if USB connection is working by creating a log file ?
When I use the -v (verbose) in the startup command it shows following :

pi@raspberrypi:~ $ sudo ./velserv -v -d /dev/ttyAMA0 -p 6000
Device : /dev/ttyAMA0
IP address : 127.0.0.1
Port : 6000
Verbose level : 1
Client mode : 1
Server mode : 1

The mentioned IP adres is not the IP adres from my PI. Can thi sbe th eissue ? In that case, how to change it since my network runs on 192.168.10.xx (using -a and IP adres does not help)

Also tried following command and results :
pi@raspberrypi:~ $ sudo ./velserv -vvvv -d /dev/ttyAMA0 -p 6000
Device : /dev/ttyAMA0
IP address : 127.0.0.1
Port : 6000
Verbose level : 4
Client mode : 1
Server mode : 1
Velserv: socket is OK…
Velserv: setting socket options is OK …
Velserv: bind is OK …
Velserv: server listen is OK …
Velserv: accepting connection
Velserv: new connection from 127.0.0.1 on socket 6

So it looks like Velserv is running but the IP adress its using is wrong.


#15

I looked to the Velserv help file and just blanked every command and retyped it in its basic format without any arguments except the port :
sudo ./velserv -p 6000
And guess what… it works :slight_smile:

I can connect now with Velbuslink and change programing.

Next step to do : get Open Remote connected and start playing with that :smile: