I have installed the new VelbusLink 7 application and connected my PC to the Velbus through USB. I manage to connect, I can see the system searching for modules, so far so good. But when the module search is finished, the system does not show the them (I wanted to attach a prt scr, but am not sure how to do this). I can also not click on the “modules” tab. Can you please help me out?


  • What interface do you use to connect to your Velbus?
  1. VMB1USB
  2. VMB1RS
  • Are you getting any errors or messages?
  • Do you see the Rx Tx lights blinking on your VMB1USB/VMB1RS while VelbusLink is scanning?

Usually when you don’t see any modules appear it means that you are connecting to the wrong port or that you have miswired something. A mistake in wiring is often accompanied by an error message in the VelbusLink software.

The modules tab can only be opened when a module is selected, and since you have none you cannot open that tab.


I am using the VMB1USB interface. I have not changed anything to my wiring and it all worked fine with a previous version of Velbuslink.
I do see the Rx Tx lights blinking and the software shows it is scanning the modules. However, at the end of the process, I do not see the modules appearing.


What version of VelbusLink do you use? (Help->About)
Do your modules have a proper address? (eg. not 00)
You are not getting any popup messages during scanning?
Do your modules see each other? (eg. they react to each other, button press -> relay on, etc)

The version I am using is
I am now getting the message “The Velbus network has entered an erroneous state. Check your wiring.” when I try to create a New Project.
The modules are reaching each other, the relays are reacting on the push buttons.

Most likely cause:

  • Check if the polarity wires (L/H) are all still connected properly, they may have detached somewhere
  • Check everywhere if the polarity wires (L/H) haven’t been reversed

Other things to check:

  • Presence of a terminator jumper. At least one should be installed on one of your modules. If you place too many, you can also get these problems (about a maximum of 4).
  • Length of the USB cable may be a problem if it’s larger than 1.5 meters (this is unlikely though, we’ve only experienced this once).

Let me know how if you make any progress

I checked all wiring (both connectivity and polarity), everything ok on that side.
I have 2 terminators, one beginning of th bus connected to the VMB1USB interface and one at the end that is connected to a VMB4PD (push button panel).

My USB cable is 1.70 meter, so I will get a new one to see if that remediates the issue.

Strange thing is that I used that same USB cable about 2 years ago to program the system with an earlier version of Velbuslink and it was working fine.

No “break through” until now!


Hello. Just to say that I am facing the same problem:
connection is OK, VMB1USB is installed, during scan the two RX/TX led blink but no board detected.

Maybe this can help: I am using Win2000 OS PC.

The point is that I will non start promoting this system until it will not be up and running as it should.

Actually is more than one year that I am waiting for a 100% working solution, and I have still not been able to see it.

Now my question is : how long have we to wait for a working 100% solution?

Do we have to wait some BTicino, Gewiss, Vimar, AVE or what else working solution?

Personally, I’d like to use Velleman, but, to be honest, Velleman is not making things easy to me.



Tried with USB cable of 1 meter…same issue.
Rechecked all of the cabling (“beeped” all the cables) and rechecked the polarity again, all connections are correct and working.
I also uninstalled Velbuslink 7 and installed version 6 to check if this would work, but getting almost the same message (“Velbuslink could not handle the traffic…”) and no modules found.

I am running out of options and getting a bit frustrated after searching for 3 full days. Hope you can help me out with more possible causes.

We’ve contacted you by mail

Hello to all,

Some possible solutions for this problem:

  • make sure every module has a different address. Notice that the address of the LCD panel has to be changed electronically.
  • Make sure to use at least one terminator. Better is using 1 in the electrical cabinet and 1 at the end of the longest cable.
  • Make sure you didn’t switch the BUS + and - at one or more modules!
  • Make sure you didn’t switch BUS and SUPPLY at one or more modules!
  • Do not use address 00 and 85…89
  • Do not extend your USB cable
  • If there are possible problems with your wiring, connect only 1 module at first
  • Be sure in your windows device manager, there is no yellow exclamation mark next to your velbus port

kind regards
Kris Daelman

Problem has been solved:

Broken wire in BUS H circuit.

If you measure the BUS between H and L, a resistance of < 250 ohm should be measured. Otherwise there is no terminator set!

Kris Daelman