Velbuslink 9.82 and vmb1dm problem

vmb1dm is not responding to actions in latest velbuslink 9.82 it was working in 9.80.

if you push 50% or 25 or 0 and send nothing happens, you have to click many times by increments of 1 % only.

Are you referring to the “operate” dialog in Velbuslink?

yes it is correct

We have tested this here and everything works fine.
Is it possible that your lamp is broken? In that case the dimmer will go into safety mode and cannot be operated.
Or maybe there’s some confusion concerning the slider in the operate dialog? You have to slide to a value (or type it in, or choose with the arrows), and then push the “Set” button.
Do the buttons “OFF”, “25%”, “50%” and “ON (100%)” work?
If you try to dim using a physical button, does it work?

lamp is ok physical button ok, dim ok.
the buttons “OFF”, “25%”, “50%” and “ON (100%)” do not work, it just increment by 1% the dimmer.
VMB1DM build 0702

and i lost the clock display in vmb4pd…

If you make an action on a button “set to 25%”, and then push the button, does it work?

no it doesnt work whatever you do it only increments or decrement by 1.
vmb1dm built 702.
here is a log , i noticed that it takes 8 min to go from 14% to 0.

14:40:08.54 0FFB1508EE030000000000816704 14 67/67 $15 (Status-Dimmer 0%) from VelBUS
14:40:08.52 0FFBC702F5043404 8 34/34 $C7 (Led:Off %00000100) from VelBUS
14:39:32.52 0FFB1508EE030120000000814604 14 46/46 $15 (Status-Dimmer 1%) from VelBUS
14:39:15.10 0FF8030400000200F004 10 F0/F0 $03 (Push: Btn N°2 released) from VelBUS
14:39:15.10 0FFB0308FB02070000000000E704 14 E7/E7 $03 (Status-Relay N°2 ON:---- Blk:----) from VelBUS
14:39:15.08 0FFBC302F580BC04 8 BC/BC $C3 (Led:Off %10000000) from VelBUS
14:39:15.08 0FFBC702F540F804 8 F8/F8 $C7 (Led:Off %01000000) from VelBUS
14:38:56.49 0FFB1508EE030220000000814504 14 45/45 $15 (Status-Dimmer 2%) from VelBUS
14:38:20.49 0FFB1508EE030320000000814404 14 44/44 $15 (Status-Dimmer 3%) from VelBUS
14:37:44.48 0FFB1508EE030420000000814304 14 43/43 $15 (Status-Dimmer 4%) from VelBUS
14:37:08.46 0FFB1508EE030520000000814204 14 42/42 $15 (Status-Dimmer 5%) from VelBUS
14:36:32.45 0FFB1508EE030620000000814104 14 41/41 $15 (Status-Dimmer 6%) from VelBUS
14:35:56.43 0FFB1508EE030720000000814004 14 40/40 $15 (Status-Dimmer 7%) from VelBUS
14:35:34.01 0FFB1508EE030820000000813F04 14 3F/3F $15 (Status-Dimmer 8%) from VelBUS
14:34:44.42 0FFB1508EE030920000000813E04 14 3E/3E $15 (Status-Dimmer 9%) from VelBUS
14:34:08.40 0FFB1508EE030A20000000813D04 14 3D/3D $15 (Status-Dimmer 10%) from VelBUS
14:33:32.38 0FFB1508EE030B20000000813C04 14 3C/3C $15 (Status-Dimmer 11%) from VelBUS
14:32:56.37 0FFB1508EE030C20000000813B04 14 3B/3B $15 (Status-Dimmer 12%) from VelBUS
14:32:20.37 0FFB1508EE030D20000000813A04 14 3A/3A $15 (Status-Dimmer 13%) from VelBUS
14:31:44.34 0FFB1508EE030E20000000813904 14 39/39 $15 (Status-Dimmer 14%) from VelBUS

very frustrating…

And the other VMB1DM’s in the installation, do they work correctly?

yes they do work correctly, but since the last velbuslink update cannot controle them via the velbuslink interface.

Do you still have Velbuslink 9.80 installed? If not, you can download it from here. (You can install several Velbuslink versions along side each other, just put them in different folders). It would be interesting to confirm that the same dimmer works well with 9.80, but not with 9.82.

they all perfectly work with 9.80.
so there must be a bug in 9.82 with older modules.

Just to make sure this doesn’t interfere: could you first of all change the address of the VMB4PD to something else than 00? 00 is reserved by the system and shouldn’t be used for modules (the latest Velbuslink versions don’t allow it but earlier versions did).

Can you specify also

  1. what kind of load these dimmers have
  2. the position of the rotary switches on the modules
  3. what actions have been configured for these modules

And another question (please see also my previous questions), I noticed your log is not the usual Velbuslink log file, what do you use to log? Are you directly connected through USB or through Home Center, or another way?
In case you are not directly connected through USB, could you try connecting through USB and see if that makes a difference?

0-changed adress of vmb4pd to 01
1- load 220 v 75W incandescent lamp
2-adresse 15 mode 3 B
3-toggle on off
4-usb direct connection

Same problem nothing resolved!

I have now been able to reproduce your situation, by setting the rotary switches to the same position as yours. There is indeed a problem in Velbuslink where the time setting is taken into account, which should not be the case.

Quick fix for you is setting the rotary switch MODE to 0, and TIME also to 0. (Since you use the action on/off you don’t need these settings). Meanwhile we’ll look into Velbuslink and hopefully correct this in the next release.

Thank you for the bug report :slight_smile:

thanks for the heads up, and i am happy that i could contribute for the debuging :smile:
FAct is I toggle on oFF with timer 1, I have kids who forget to switch off lights (hope you undestand me :wink:

I will eagerly wait for next release.
should i use 9.80 version and resign not to upgrade velbuslink?

thank you for fixing the issue in latest 9 84 0 3 version.
i knew i could count on you :wink:

what was the issue? thanks

The time parameter that is set in the packet, was wrong.

1 Like

can you post right time parameter?
thank you

For 1DM this packet is

Meaning that the last two bytes should be 0xFF 0xFF to have the fastest dimtime.

Kind regards

1 Like