VMB2BLE protocol


Can i download the protocol explanation for the VMB2BLE somewhere? I couldn’t find it on the website.

thank you!

The VMB2BLE protocol is not online yet. If you want to cheat, you can use the VelbusLink to issue a command an then use the logging window to analyze that command.

yes i know, that was my next option if the manual wasn’t available. Since this is for a customer it would be easier to have the manual so we can program everything before actually going to the customer.

thank you for your reply!

Here you go:

VMB2BLE protocol (PDF)

Thank you!

The PDF doc isn’t very accurate about this : is the module able to memorize it previous status (example : Blind down, stop. 2 hours later I want to know the blind status, is it down (then I’ve to do an up command) or stop (don’t know the last state) ?)

To know the blind’s status (moving up, moving down, idle), send a ‘Blind status request’ (page 13). Then intercept the ‘Blind status’ (page 7). The blind will report its current status.

You can use this to customize the action that you want to perform. If the blind reports that it is moving up, you can enable ‘stop’ or ‘move down’, etc.


i’m having soms issues with the timeout parameter in the protocol.

If i send 0F F8 20 05 05 01 00 00 02 CC 04 to the velbus system, blind 1 at address 20 goes up, but doesn’t stop after 2 seconds.

Am i missing something?

Thank you!

This command is correct and works perfectly for us, when sent with VelbusLink.


i tried this in 3 different ways:

PC connected to vmb1usb and using velbuslink: not working.
PC connected to VMB1RS and using velbuslink: not working.
Crestron processor connected to VMB1RS: not working.

The blind controller keeps using the time set to it in velbuslink, no matter what command i send to it.

the controller is on firmware 1325.

Indeed, you are correct, after changing the time values in the configuration dialog, the command does not time out properly anymore. We will check why this happens.

Ok, thank you!

Good news everyone, the cause of the bug has been found and will be solved in the next version of VelbusLink.

Good news indeed!

Thank you!