VMB4DC - Multi-Step Dim does not work

This problem is easy to replicate.
VMB4DC with firmware 2048. 0-10V connected to Finder 15.11 Slave Dimmer.
VMB8PBU with firmware 1822

Manually setting the DIM value of the VMB4DC in “Operate” works as expected.
If I set a pushbutton to 203 (Memory or OFF, hold to dim) then it works as expected.

I can configure the step dim values for the VMB4DC (100,75,50,25,0) OK

But if I then set a VMB8PBU initiator pushbutton to multi-step dim then it does not work.
When I press the button, the DIM value just changes by 1 each time.

The same switch of the same VMB8PBU can multi-step dim VMBDMI-R dimmers just fine. I only see this problem with VMB4DC.

This is too specific for me to reproduce freely. But it looks to mee that you possibly may still use the 0202 command tied to the button, where you need to use the 0215 command to use the multi-step feature.

Can you report this at

help.velbus.eu please?

need to use the 0215 command to use the multi-step feature.

Definitely was trying to use 0215 to multi step dim as above but it did not work. Thanks.

Can you report this at

Have just done so, thanks.

All good otherwise. Everything is coming together nicely.
Still not making much use of all of the PIRs. They were supposed to be to turn on dim lights in case of wandering about at night but I haven’t done much of that yet :slight_smile:
I was also wondering about also using them to detect non-occupancy to turn up multi-point extract ventilation wen no-one is here in day-time (we have radon. It is better since house makeover but still noticeable when windows are all shut).

  • Andy
1 Like

Speaking of which

Have you formally registered your Velbus installation yet, to activate the 10 year warranty?


8 years!? That’s good.

I registered on 25th Feb 2021. Almost all the dimmer and relay modules were installed then.
Most of the light switches (all VMB8PBU) took a bit longer as I had to wait for second fix and decorating to be finished.

But at that time the warranty extension was only to 5 years.

Everything has worked fine so far except one VMBDMI-R which was unreliable from the start. I replaced that and meant to send in the faulty one but didn’t get around to… not sure where I have put it now :-/

The builders were very surprised back in 2021 when, before we had any light switches, I gave them a 3-button light switch with no wired connections.
It was a cheap RF switch from Amazon that activated a relay on a VMB8PBU in the loft that turned all the main lights on, or off (just with temporary cheap LED GLS bulb fittings then - we were saving the main Aurora downlights until it was all cleaner).

It has been very handy to put all the light switches in without having to decide in advance what they all do. The initial switch setup started as simple toggles with one button per lighting circuit but since then we have switched a few around, added some ALL-OFF groups on long presses, also using a few timers for lighting, towel rails, bathroom ventilation fan overruns etc

It has taken quite a bit of work (and time) to figure out and set minimum DIM values for different types of lamps (still working on that too - some unwanted delays here and there), and to find (and swap-in) good dimmable LED drivers and replace bulbs that did not work well with the VMBDMI-R. Altogether though we are very pleased with it.

  • Andy

Yeah, tricks like that really impress people.

I have installers who don’t final fix the glass panels / switchgear until after the decorators have left.

Well, across the board it is now 10 Years from point of installation, so do register your second phase separately to get the full duration from it.

I wish you had mentioned that, we would have changed it for you.

That is indeed one of the absolute best advantages of most digital systems, but especially Velbus, as it can be adapted on the fly without much hassle.

I just wish I could get more contractors to look at it seriously… All I ever hear is things like, “it’s just like KNX / Lutron etc, that’s too difficult / costly” and then the interaction stops.

I won’t repeat what one guy said to me on the phone yesterday,

Thank you for that, it’s lifted my spirits after an unpleasant day of sales calls.

If you have time, would you consider writing a blog or whitepaper on your experience?

Thanks a million

Hello @EvAndy,

We have recreated your problem here. But we cannot reproduce the error.
We ran the test with the latest VelbusLink 10.9.7 version together with VMB4DC FW Build 2048 and VMB8PBU with FW 1822 ==> We were unable to reproduce the error.
This with both actions: 0203 and 0215 => everything works correctly here.

This is why we suggest you to using the latest VelbusLink version.
Can be downloaded from here: https://cdn.velleman.eu/downloads/velbus/velbuslink/velbuslink-latest.exe

Please also try this:
Perform a FULL write only on the VMB4DC module.
=> go to Synchronize => Check only the VMB4DC, and uncheck all other modules => uncheck “changes only” => and synchronize (this is how a full write is performed => the entire memory map is written to the module and not “only changes”).

If the problem is still not solved by applying the above method, we would like to receive your latest VelbusLink project file (VLP). This way we can investigate the problem further.
You can send the vlp file in ticket number: #8049 => via ticket system => https://help.velbus.eu

Kind regards,
Velbus Team

1 Like

Hi VEL450/Xavier

Thanks for looking into this.
I just upgraded my VelbusLink 10.9.6 to 10.9.7
and then I changed my setup back to step-dim (215) on PB2.
and then I synced with the VMB8PBU and VMB4DC with “Only write changes” unticked.

and that seems to have fixed it. Multi-step dimming is now working OK.

So perhaps it was something to do with a previous setting and “Only write changes”.

I any case, I cannot reproduce it now so I guess is OK to close the case.
If I see anything like it again I will open a new case.


  • Andy
1 Like

Hello Andrew,

Thanks for the feedback, and nice to here it’s working now.
We are closing this ticket.

If the problem occurs again later, you can open a new ticket on:
https://help.velbus.eu and refer to this ticket no: #8049

Best Regards,
Velbus SL2 - Tech Service