VMB4RYLD Failed Update Help Required

I’ve just tried to update the firmware on a VMB4RYLD to 1927 as advised by the Velbuislink software. The update got to 100% and hung at that point. The module will no longer work from the glass panel PBs but I can operate each relay from the module itself through Velbuslink. When i try to operate the module relays through the velbus link virtual glass panel it also wont activate. I assume something went wrong with the update process. I tried factory reset and re wrote the config to it but the same results. If I try to set up the links again I get an error when I try to set its function to toggle. Any help please as its a vital lighting module that now wont work


Can I suggest you do a full write to that module.

Use the sync, only tick that relay, untick the “only changes”

Then click write.

(This is actually the last thing that the firmware update tool should have done)

Please do update this thread afterwards.

Good luck.

1 Like

Perfect, thank you for you help, all the lighting systems are now fully functioning from the glass panels or from Velbuslink.
I assume then that the update process has worked its just the final write back to the module that repetitively failed as I tried the update process and factory default numerous times with it hanging at 100%.
Thanks again for your fantastic help

1 Like

I had the same problem last when I tried to update a blind module. I was afraid that I ruined the module and let the last step run for the night.
With a small hart I restarted my pc because I still hung in the last step. After a power cycle ofnthe complete system the module was recognized with the right firmwareversion so the logical step for me was to rewrite it s settings and got it working again.

I think there s something wrong with velbuslink updating the modules in the last version if I read the first story. Can somebody from Velleman try the cycle out?

1 Like

We’ve had this report some time ago specific for the blind module, but we were unable to reproduce it so far.

1 Like

I’m not seeing this issue with the module I reported it for, since I swapped to velbus-tcp snap.

I think the issue is that VelbusLink misses the very last Packet from the module, signalling that it’s completed the Firmware upgrade, so doesn’t move on to writing the configuration.

Which is why a full write resolves it.

I assume you’re connecting with VelServ, does the issue happen if you connect directly over USB?

I am still seeing that (server) Buffer Full error in the velbus-tcp log.
It doesn’t seem to be affecting the performance or behaviour

Are there special packets being used when update a module. Velserv checks for every packet if it starts end ends with the right given delimiters. What’s the maximum message lenght?
I also was thinking velserv could be involved but didn’t tried it straight on usb communication.

Stuart: We haven’t been able yet to look at the velbus-tcp snap. Buffer full can appear when too many messages are being transmitted or received. I might confirm that it doesn’t affect your performance or behaviour since it stacks the messages to transmit them later when the buffer is empty again.

Jeroen: That should be fine, we cannot introduce a special kind of packet structure since we still support the modules we sold back in 2008. :slight_smile: The start and the end flag are always the same and will not be changed. The maximum packet length is 14 bytes. (See: https://github.com/velbus/packetprotocol)

We’re going to investigate the cause of this issue. Currently we haven’t been able to reproduce it yet. If you have encountered it, a packet log will help us further to find the root cause of this.

1 Like

I’ll try to do an update of another vmb2le module and log all packets. I can log the packets with velserv and write them in a file, can velbuslink do the same while updating?

1 Like

We have a tab page “logging” next to “welcome” and “actions”. You can save and load logs there. :wink:
Surprisingly, I just spotted a “logs” button in VelbusLink where previous logs are stored temporary.

1 Like


Where’s that?

Just next to “Load Log” there’s a button “Logs” which will open a file with older log files.

1 Like

So there is…

Apparently I have 359 log files in the revealed folder

Ok, didn’t know Velbuslink stored automaticly all the logs :slight_smile:

1 Like

This is not an obligation but it would help us a lot if you would be able to find the packet log in the archive. In the folder, each file has the project name in it, so if you can remember the project you’ve encountered this in, you might be able to find the packet log where the update failed to finish. Consider forwarding this to support@velbus.eu or sending it with a private message to us. Thank you.

We’ve resolved this issue in VelbusLink 10.6.4, thanks for reporting the issue!

1 Like

just a note that updating my VMBGPODW required a manual full sync … as it did not rewrite the configuration back with Velbus 10.6.4

I think you may need to download the latest VelbusLink. There was a bug in v10.6.4 where in some cases the memory write doesn’t start after the firmware was successfully flashed. :slight_smile:


Sorry that I didn’t found the time to create a log for you guys, but happy that the bug was found :slight_smile:

1 Like