VMBDMI master+slave not behaving right

I have three VMBDMI-R that I want to dim together.
So I configure the main one to be master with a “203 Dim at long press…” action from a VMB8PU button (on channel 4). I clear all actions at the other two and then set SLAVE following initiator (213) actions for them with the Master VMBDMI-R channel 1 as initiator.
They switch on and off together just fine. But trying to hold the VMB8PBU button to dim is strange. The Master does not dim, it just stays at 100% but the two slave channels do dim as expected.
Am I missing something?

I just tried step-dimming the master instead of smooth dimming it… same result… the master stays at 100% but the slaves step 60%, 100%, 0%

Update: It looks like my minimum dim value is causing the trouble. If I leave it unset (0%) then it mostly works. But if I set min dim to 60% then it behaves as above.


I should add that I NEED the minimum dim value… if it worked.

Some of my LED lamps don’t do anything useful until >50% so if I don;t have a dim value then they appear off during the initial fade-in from 0% to 50%… which give the impression of a long delay.

I need minimum dim values to supress this delay.
BUT that does not work with master+slave dimming :frowning:

I’m not sure how to address the issue with just VMBDMI-R units, that’s something the core Velbus team with have to address.


Do you ever want to be able to dim the different circuits independently?
Or do you always want to treat them as one big group that dims in harmony?

Do you have a channel of a VMB4DC spare?

I’m not sure how to address the issue with just VMBDMI-R units

It certainly seems like a bug in the way min dim values are handled in master dimmers.

I need to be able to have one LED downlight on without the others. The rest of the time they all should dim together.

LED3 needs independent control but is also always on if LED1 and/or LED2 are on.
LED3 is a single downlight over a spiral staircase. It feels safer with this LED on.

I do have a VMBPIRM in the area for extra control too. This would only turn on LED3.

LED1 and LED2 are chandeliers. Turning those on in response to the PIR is just “a bit much” :slight_smile:

There certainly seems like an edge case issue with setting a high minimum dim level on a master dimmer.

I haven’t got a demo unit with more than one VMBDMI-R, so I’ll have to test this in a room in my home.

I’m sure the Velbus team can rig something to test this.

As for the logic you want around the three dimmers, this might be a situation where a small NodeRed deployment on your Pi Zero might work nicely?

You can easily add time / day / duration conditioning to the Flow.

The NodeRed Velbus pallette is a little limited, but it certainly has enough to get this working for you.

I’m happy to help if needed.

Hello @EvAndy ,

The problem may be due to the type of load “LED” and or the brand.

You can try to enter a higher percentage for the min dimming value.
For LED lamp, it is best to choose the type Inductive as setting.

However, we cannot guarantee that a LED lamp of a certain type / brand will work in combination with a VMBDMI-R dimming module.

The only way to find out whether a certain LED lamp works with this dimmer is to determine it experimentally.

An additional problem is that the manufacturers of LED lamps frequently change the design or use different components, which means that a certain type of LED lamp may work, but the same type from another lot will not work.

We recommend using a VMB4DC module in combination with a Finder dimmer (FIN15. or other 0-10V controlled universal dimmer for 230V LED lamps.

Depending on Master / Slave dimming:

For master / slave function, see also Tab "Advanced" when configuring the module VMBDMI-R.
Put the check mark there in function of master or slave dimmer => see explanation in advanced config.
Possibly it is set wrong.

Velbus Team


I think Andy is looking for the next level of answer.

We can safely assume that he has done all of above.

Thanks VEL450.

If I choose “inductive” then none of my LEDs work at all – I get blinking-panel-led errors from almost all the dimmers.

Inductive mode is only suitable for old iron-core transformers. I have 106 VMBDMI-R on this project, all are happier on “resistive”. I am very aware because they all default to inductive… this caught me out initially, I thought they were faulty. I had to configure them all “resistive” manually. Your own configuration settings emphasize that “Resistive mode – Dimmer suitable for… dimmable LED lights and some electronic transformers…”. Almost nobody uses iron-core transformers any more. These devices really should default to resistive. Inductive setting will result in LED-flicker or errors.

I have a mix of Aurora MPRO (1A and 2A) downlights; from 1 to 8 per dimmer. With also some separate chandeliers with SES LED lamps, and some wall lights with SES or ES LED lamps.

All lamps are major brands (OSRAM, PHILIPS, TALA) dimmable LED filament.

And for LED strip-lighting I have some constant current and constant voltage dimmable LED drivers all carefully chosen.

I have been testing and using the Aurora downlights since 2019 and all revisions since (E8, MPRO 1, MPRO1A, MPRO2 MPRO2A) have worked very well.

For the most part they all great. Really smooth dimming, no flicker at all anywhere. None of the problems I see with most push-dimmers, even L+N powered ones.

Main variable is the dim level at which they come on. The LED drivers I use come on at around 15%. The downlights at about 40%. The SES bulbs at about 50%.

So to be able to configure minimum dim value is great and it normally works very well… but not in master+slave configuration… there you clearly have a firmware bug.

I am aware of the VMB4DC+Finder recommendation… it was made shortly after I purchased 70+ VMBDMI. Too late for me to change. I was not amused.

And I must say… the VMBDMI-R are working fine. I do have just a few VMB4DC and FIN15.… they do not work any better for my LEDS (though they are slightly more compact at 6 vs 8 DIN rail units for 4 dimmers) and most importantly they are a pain to wire-up bus connections in volume because they cannot use VMBRAIL… too many flying wires (think about wiring for 100+ dimmers).

I have been using Velbus since 2010. I use VMB4DC to control my ventilation fans. I use VMBDMI-R to control my towel rails. I have 30+ home-made wall switches using VMB8PBU (these are really nice, I should post photos here).

I was an original investor in many VMBDME… (your previous trailing-edge dimming solution for electronic loads like LED) which did not go well.

Those were replaced with VMBDMI.

And then those were all replaced with VMBDMI-R.

And now you have no in-house trailing-edge solution at all :frowning:

Please do not get me wrong… I love Velbus. I want more Velbus. There is a lot that is great about it. But we need a new dimmer product.

I would love to see a properly configurable reliable 4-channel 230V AC dimmer, configurable for leading or trailing edge, in a 72mm span. I would use those in new projects. And if you have anything in development I would be happy to test it.



Hello @EvAndy ,

To investigate this further, We would like to know how many Master dimmers in total you have in your project. We would also like to receive the .vlp file. This way we can check which firmware the modules have. You can send the .vlp file in private message.
Are you also using the latest VelbusLink version 10.9.4?

Best Regards,
Velbus Team

Hello @EvAndy ,

To investigate this further, We would like to know how many Master dimmers in total you have in your project. We would also like to receive the .vlp file. This way we can check which firmware the modules have. You can open a new Velbus Ticket on: https://help.velbus.eu/ there you can upload the .vlp file in
Are you also using the latest VelbusLink version 10.9.6?

Best Regards,
Velbus Team

Hi VEL450

Yes, I am using 10.9.6
I only have one master dimmer in my project… this was the first time I have tried to use this feature.

I have figured out that the problem is to do with minimum dim values. Before setting up master slave I need to set minimum dim values for ALL lamps so that they behave the same.

The problems here arise from the other issue I reported here :-

With MIN DIM=0% my Lobby and Porch chandelier LED lamps start to operate at 60% dim. BUT the correct MIN DIM value is not 60%, it turns out to need 25%.
ie. MIN DIM=0% and my lamps illuminates from 60% to 100%
but MIN DIM=25% and my lamps illuminates from 1% to 100%

Similarly, with Aurora Mpro downlights
MIN DIM 0% and my lamps illuminate from approx 40 to 100%
but MIN DIM=12% gets me a good range form 1% to 100%.

So I have learned that it is important to set min DIM correctly for ALL lamps in a master/slave setup BEFORE trying to operate them together.

Most importantly the % used for MINIMUM DIM is NOT THE SAME as the % used in dimming. This makes it very difficult to setup… only by trial and error. I hope you can do something about this as it makes finding suitable minimum dim values quite difficult.

My velbuslink project file is attached FYI.
The Master in this case is US-LOBBY-Pendant (a chandlelier with several LED filament lamps)
The slaves are US-PORCH-Pendant (a smaller chandlier with same lamps)
and US-MainStair-DL, and Aurora MPro fire-rated downlight assembly.

TOG01.vlp (302.9 KB)

Can I suggest a suitable UI?

How I would like to set minimum dim values…

  1. Load project, connect to velbus and scan, all as usual.
  2. select to “Operate” a dimmer.
  3. Adjust the SET slider to the point where the lamp illuminates dimly
  4. Press a button to set minimum DIM value for this dimmer.

I would also like step 4 to display what that minimum dim value is (it is NOT the same as the dimmer % although perhaps it should be). This step is still necessary because once i have determined that minimum dim value for eg. Aurora MPro (of which I have approx 80 lamps in this project), I would like to set them numerically as usual, rather than using the slider as I do for the first one).

This would make trying out new lamps and initial setup much easier.


Hello @EvAndy ,

This feature request will be integrated in upcoming velbuslink version for dimmer modules and VMB4DC. So that adjusting the min dim value in VelbusLink is easier with the help of a “Preview” button or “slider”. So that you can see the set value live with connected LED lamp on dimmer. This way you don’t have to set up and sync every time.

Best Regards,
Velbus Team

1 Like