VMBGPOD wrong sunset times


When using sunrise and sunset times on 12 Nov 2016 on a VMBGPOD I notice that the sunrise time that Velbus executes a program is more or less correct.
Program is executed at 07:52, while actual sunrise is 07:54: so OK for me.

The actual sunset time is 16:59 and the velbus program gets executed at 18:52…exactly 11 hours after sunrise!
When checking the sunrise/sunset time on the module I see the following:
05 Nov: 07:41–>17:11
21 Nov: 08:07–>16:49

Anyone any idea what is happening here ?

Velbus VMBGPOD build is 1521.

Thx for any help.

This is a firmware bug in the VMBGPOD.
We just put a minor Velbuslink upgrade online ( with the latest VMBGPOD firmware in it. Download at the usual location.

Could you try installing it and upgrading your VMBGPOD firmware? (You’ll have to go in service mode by pressing Ctrl+SHift+F10, then type the displayed number backwards, then rightclick on the VMBGPOD and select Developer > Firmware Upgrade). The VMBGPOD firmware upgrade can easily take 10 minutes, and it is advisable to cause as little traffic as possible on the bus while it is going on.

Before starting the firmware upgrade make sure you first sync (read) your project, because at the end of the upgrade the VMBGPOD config from the project is written again to the module.

I suspect the VMBGPTC with firmware 1521 to suffer from the same issue.

Probably true, the firmware is very similar. And the same will go for the VMBGPO.
The VMBGPTC and VMBGPO however are not upgradable through Velbuslink. You can send them back to us at Velbus (ideally through the sales point where you bought it, or otherwise directly) and we will upgrade them free of charge.
Please note that after the upgrade it will be reset to factory defaults and will have to be reprogrammed by you.

Dear Vel345,

I have downloaded your new Velbuslink and upgraded one of my VMBGPOD’s today at noon.
This evening a couple of minutes before 17:00 CET my light switched on… so your firmware update is working as expected.

I noticed that during the upgrade the clock setting of the VMBGPOD was lost - may be something to incorporate in your next releases ?

I will start upgrading my other VMBGPOD’s now and hope all goes well.

Many thanks for your quick support !



Although the sunset now correctly functions, the screensaver function does not work anymore.

I have tried factory reset/power off but nothing helps.

Can you check if the modification for sunset changed anything on the screensaver function ?

I will hold off upgrading my other VMBGPOD’s

Thx for a reply.

What do you mean by “screensaver does not work anymore”?
How was it before (dimmed, turned off)?
And how is it now (always lit, dimmed, off, …)?

Dear VEL345,

Setting was: “Turn screen off after 15 seconds” with “operate buttons immediately”

After the upgrade to build 1642 the screen is always lit: so it does not dim or turn off anymore.
Setting in Velbuslink did not change. I have rewritten the VMBGPOD with different combinations of dim/turn off but the OLED screen always stays on…

Hope this info helps to solve the issue ?

Thanks for your excellent service up to now.


Correct, we overlooked the firmware changes concerning the screensaver in the, our apologies for that.
All firmware changes will be correctly handled by the next Velbuslink version (9.82), but this is still in beta and not ready for publication.

I removed the 9.80.010 version from our website and put the back in place.
If you already did the VMBGPOD firmware upgrade, I will post a packet here that you can send on the bus to fix the screensaver issue (instructions will follow below).

For those that have not been upgraded, better wait for the next Velbuslink version 9.82. (Subscribe to our update newsletter to be informed when it comes out).

If you prefer, you can also downgrade the VMBGPOD to its previous version by re-installing Velbuslink (now online) and perform a firmware upgrade with that one. That should make everything again as it was (including the sunset bug of course).


Thx for the clarification.

Pls let me know how to get the special packet to correct the screensaver issue.


For the packet:
go into logging (tab next to the actions tab)
click on the “New” button
a dialog appears “send a packet”; fill in the following:

  • priority: low
  • address: the address of the VMBGPOD (master address, not of additional pages or thermostat)
  • data size: 4
  • data byte: FC02EE1E
  • (leave RTR unchecked)
    press send
    next, send a second packet in the same way:
  • priority: low
  • address: the same address as before
  • data size: 4
  • data byte: FC1A03FF
  • (leave RTR unchecked)
    press send

After you have operated the VMBGPOD once (push a button for instance), the screensaver should work after 15 sec.

Please note that from now on (until the new Velbuslink comes out), you should only “write changes” to this VMBGPOD, if you do a full write to it (with “only write changes” unchecked), the screensaver will be broken again.

If you would encounter more problems, I would advise a downgrade of the firmware as explained before.


I have sent both commands and the module now dims the OLED screen.
With Velbuslink I have sent a “Turn screen off after 15 secs” with write changes only and this now works as well.

I will test the sunset functionality again tomorrow and hold off upgrading my other VMBGPOD’s until 9.82 comes out.


I have firmware version 1612 on VMBGPOD and I have experienced a similar problem as leoke described in the first post. I updated to version 1720 with Velbuslink and the problem is solved now.