Velbus binding for OpenHAB


#21

Tried with old install, not working.

installed your addon market:binding-3913441 - 1.0
i am doing a clean reinstalled openhab 2 3 0 build1251 …

not working even after clean install of latest onpenhab and bindings.
When using the slider it is forced to default value of 32 % (like it’s displaying packet value" 32 "for 50%) , on off inneffective.


#22

compared the previous and new binding they have same build :binding-3913441 - 1.0

are you sur you uploaded the right file? it happens :slight_smile:

I physically checked dimmers , they receive packets and led blink respectively, but no action.

noticed in packet with velbuslink log:

100 % is : 01 64 00 01
50% is : 01 32 00 01
0% is : 01 00 00 01


#23

I haven’t updated the binding on the Eclipse IoT Marketplace yet. If you want to try the latest changes you will have to uninstall the binding from the market place, and put the latest version I send by wetransfer in your “addons” folder.
If this still does not work, I will have to add some extra debug information to the logs.

The vmb2bl will require more effort, and since I’m currently focussing on getting a first version of the binding approved, it will probably be a while before I will be able to include it.


#24

That’s what I did
I installed your binding: is it the one I mentioned above?
Biding is only installed in addon folder and not through market.

How could I help for vmb2bl?, I know I have a learning curve with eclipse…
I have an idea, is it easier to bind VMB8PB ? I could control blinds that way.


#25

I did that on openhabian@openHABianPi:/usr/share/openhab2/addons$, then restarted the pi, but no new binding.
Should I see a new binding in PaperUI?

thanks for your help!


#26

Yes
When you scan for new things you should have velbus.
Make sur you choose a com for velbus bridge


#27

Just received a reply from vel, we had same issue with 9.82 velbuslink, fixed in latest vers.

Time parameter set in packet was wrong!

Hope it will help


#28

Cool - It works! :wink:
Thanks for bringing this Addon to openHab!


#29

Do you have older modules like 4ry, dm1…?


#30

Hello Cedric
Is it possible to have vmbp8
Thanks
Up


#31

Hello Cedric
Any news?
Thanks


#32

Hi Ciceron,

I have a new build that should support the vmb1dm, vmb2bl and vmbp8.
However, I haven’t found the time to test it properly yet.
You can already give it a try if you want, but I won’t be able to make any changes before the end of next week.

https://we.tl/kSIAXXC3KS

Regards,
Cédric


#33

You rock cedric
I will keep you posted…


#34

vmb2bl vmb6in vmbpb8 are all reconized.

BUT

1-Vmb2bl doesnt work

2-Dont know how to add as item vmb6in and vmb8pb

\3-Vmb1dm is accepting commands but only after multiple clicks, we had same problem in velbuslink, problem was fixed The time parameter that is set in the packet, was wrong. according to VEL448
:slight_smile:Velbuslink 9.82 and vmb1dm problem

‘‘Meaning that the last two bytes should be 0xFF 0xFF to have the fastest dimtime.’’


#35

installed openhabian in Raspberry pi 3b, its up and running.
i put the jar file SNAPSHOT IN \OPENHABIANPI\openHAB-share\openhab2-addons
Installed velbus binding, serial binding , iot ,
but doesnt show on configuration binding…
any clue?

SOLVED
Needed to install through ssh snapshot version :wink:


#36

Very satisfied with openhabian in rpi 3B


#37

Any news Cedric?
Thanks
Have a good we


#38

Hi Ciceron,

The timing problem of the vmb1dm should be fixed in the last version I send.
The binding should now send exactly the same packets as in your screenshot of the VelbusLink logging.

I build a new version with extra logging:
https://we.tl/EBXvhmibAT

This version will output the packets that are send for the vmb1dm and vmb2bl modules in the openhab.log file.
Can you try it and compare the packets with the ones that are send from VelbusLink?


#39

unfortunatly not working.

for all things i receive:
2018-05-04 18:45:34.517 [hingStatusInfoChangedEvent] - ‘velbus:vmb2bl:289df891:D6’ changed from INITIALIZING to UNINITIALIZED (HANDLER_INITIALIZING_ERROR): org.eclipse.smarthome.core.util.HexUtils.hexToBytes(Ljava/lang/String;)[B

I tried older Bindings in same config, no issue in status…

tried the whole day, no luck…

Thank you


#40

is it possible for someone to put the img of the pi online once that works? greetings Joram