Velbus binding for OpenHAB


you already have a working one with newest moduls


Hi Ciceron,

Can you share the full log file?
The message seems to say something about the hexToBytes function, which is used to convert the “address” setting of your Thing to a byte. But from the portion you posted I can’t see what’s going wrong.


sur right away
I think all that time i was installing repository binding, have to check :frowning:


openhab.log (95.6 KB)
This the log of repository binding not latest one.
i am preparing a log with latest snapshot binding

I am experiencing same problem even with repository binding…now


i deleted everything.
rebooting computer.
reinstalling 2.3 snapshot
putting your snapshot binding in addon folder
launching start.bat
opening http://localhost:8080/start/index
choosing simple Ui
configuration>system>access remote repository OFF / autoignore ON/ autoapprove ON / simple mode linking ON > SAVE
Configuration>thing + >Serial Com choosed ONLINE

  • seaching for things

Output: no thing found, but listed in configuration>things as UNINITIALISED

AM I doing something wrong??

This is the log of YOUR latest SNAPSHOT binding.
openhab.log (901.3 KB)


Hi Ciceron,

I found the following line in the log file:
java.lang.NoSuchMethodError: org.eclipse.smarthome.core.util.HexUtils.hexToBytes

Actually, the hexToBytes method is a method that has been added to the openHab snapshot version only a few weeks ago.
The fact that the method cannot be found could indicate that you are not running on the latest snapshot version of openHab, either because you are running on the Stable version, or because your Snapshot version is from before the addition of the hexToBytes method.

If you are running on a raspberry pi, can you try to switch to the latest snapshot version using openhabian-config -> openHAB related -> openHAB unstable?


hi i am running on windows
where could i find latest snapshot, couldnt find latest
i have 2.3.0 snapshot of 26/03/18.
many thanks

though cloudbees was down


Ok, that explains it, the hexToBytes method has been added on 31/03/2018 :slight_smile:
You can find the latest snapshot version on CloudBees:


reinstalled build 1971, binding in addon.
I cannot see velbus binding?
what should i do activate remote repository? install iot market?

I installed iot market, and installed from ADDON>BINDIND>binding-velbus - 2.3.0.SNAPSHOT

vMB1DM AND VMB2BL not working.

lof file :openhab.log (124.7 KB)

Nice packcets added to log!!!

I noticed when lamp at 100% real, slider is at 64%, and it takes like 5 min to aknowledge commande


for comparison here is a log from velserver, dimmer at 0% and 100%
PB_Velbus-server_2018-05-04_23-09.log (967 Bytes)



You shouldn’t install anything from the iot market, because the version from the iot market is still an old one.
Just put the jar in the addons folder.

If you see the error “Unresolved requirement: Import-Package:” in your log file, you can try entering “feature:install openhab-transport-serial” in the Openhab console. This should explicitely install the package that is currently missing…


@Ciceron: with the logging I found a bug in the detection of the 1st gen vs 2nd gen device.
Can you try this new version?


Better behavior,

OFF : ok
ON : not working

slider ok but doesnt reflect real %
real 100% : 64% slider
if you CLICK on slider : needs to press 2 times to get middle value (if you choose 13% or any other value it goes to 32 % and after 2nd push it takes the choosed %)

VMB2BL WORKS!!! cool
and name modules are read!
thank you cedric :smile:


HELLO Cedric
Any news concerning vmb1dm issue.
How could i add vmb8pb and vmb6in as things?
I see them but couldnt interact in any manner with those modules.


Any news?


Any update Cedric
Concerning the above?


Hi Ciceron,

Here is an updated version that should fix the slider behavior:

Regarding the ON-command, can you check the Build number of your VMB1DM?
The command that is used is available since Build 1006.

The VMB8PB and VMB6IN have “trigger-channels” that can be used in rules to make openHAB react to changes on these channels. (See


NEW binding not working:

slider stuck at 32% and no action ,
ON not working

Build 702



The VMB8PB and VMB6IN triggers not detected.


Hi Ciceron,

From your previous post I assumed the maximum dim value for the VMB1DM was 64, so what I did in this version is:

  • When sending a packet using the following value as dim value: (slider percentage / 100) * 64
  • When receiving a dim status setting the slider at the following value: (dimValue /64) * 100
    Any idea where it goes wrong?

The ON functionality wont work on build 702, as it requires at least build 1006.
But once the slider is working, you can easily achieve +/- the same behavior by creating a virtual switch item and a rule that sets the dimmer value to the wanted ON-state (e.g. 100%).

What do you mean by the VMB8PB and VMBIN triggers not being detected?
Do you see the trigger-channels in openHAB?
Is there anything related to these channels in your log file?