Velbus binding for OpenHAB


#81

info about the (old) dimmer:

This is maybe the reason I don’t get any updates from the dimvalues …

I don’t know if it helps you but I always used the slider command in my programs:

This gives you more data (it updates the values in between the sliding, for ex. when you have a slow on dimmer). The other command trasmits the dimmer value at the end value.


#82

woooww Thanks Tom. The full config is in the zip. Amazing. Thanks. I’m a noob with openhab. Learning fast.

do you use the iPhone or Android App?


#83

Acting strange. It cycles through all modes and then end up doing a random setting. It even moves to cooling if I configure the heating modes.

Strange


#84

Hi Jeroen,

Thanks for pointing out the difference in position of the dimValue!
Here is a build containing this modification:
https://we.tl/74gCGq7HCZ

(I also tried the “Slider status” command, but this causes some very strange behavior in openHAB: the openHAB slider flips back and forth between the old and the new slider value, and ends up at your previous setpoint)

@Ciceron: This might solve your problem with the vmb1dm as well


#85

Maybe a “noob” question, but can I just overwrite the old jar or …?


#86

Yes, you can overwrite the previous jar.
Then you can either restart openHAB or wait a few moments until it detects and reloads the new module.


#87

I Was away from home .

Good news fellas !

last binding corrected dimmer behavior: tested on windows and RPI

1-reads the value from the physical buttons we get correct feedback
2-0% and 100% match
3-Slider on openhab control works
4-OFF works

ON not working

question: did you code it to show last value before setting new one?
( exemple: current value 20% , new value 80% , BEHAVIOR: it will slide back to 20% and then sets back to 80%)
at least it doesnt show 32% anymore

Thanks


#88

SOLVED: WORKING ON RPI, UNINSTALLED repository velbus binding and desactivated repository access.

not working on RPI, no shutter, no dimmer.
maybe i need a clean install!!
any clue

2018-06-18 11:37:27.739 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.velbus-2.3.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.velbus [240]

Another singleton bundle selected: osgi.identity; type=“osgi.bundle”; version:Version=“2.4.0.201806040927”; osgi.identity=“org.openhab.binding.velbus”; singleton:=“true”

at org.eclipse.osgi.container.Module.start(Module.java:444) [?:?]

at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) [?:?]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [9:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [9:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles(DirectoryWatcher.java:1221) [9:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:515) [9:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [9:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [9:org.apache.felix.fileinstall:3.6.4]

#89

No, but the Velbus module is sending a status message with the current value before sending the status message with the target value. I haven’t figured out an easy way to optimize this behavior yet.


#90

Well at least we have the correct value.


#91

Everything works perfect by me. Top!

Maybe I can secretly ask to add support for the vmb1tc :blush: ? I’ve got 8 of them in my installation, so it would be very very nice …


#92

Hi
Dont you have the slide back?
What is your config?
Openhabian, binding, vmb1dm version…

Thanks


#93

I do have a slide back, but that’s probably because it now listens to the bus and adjust it’s fader to the value send.
A small refinery could be done in the trend of:

While( “command send internaly” and “value received from dimmer <> value set +/- 5%”)

       ignore received value;

}
set slider to last received value;


#94

Hi

Just to throw my thoughts on here…

I quite like the way the slider bounces between the new value and it’s current dim level.

It does show that there is a good connection to the Velbus network, which can be very reassuring that the module has received the instruction.

Cheers,
Stuart


#95

No problem Geert,
I use android, but not the app. I pin the webpage to my home screen. I think this is the preferred way in OH2.


#96

@tomvancutsem @gverbist

One tiny consideration.

I prefer the web browser (HabPanel) interface to OH2, but mainly because I can’t get my head around Sitemaps.

However, if you want notifications pushing to your handset, I think you’d need the OpenHab app running in the background and connected to myopenhab.org

Not that I’ve worked out how to push notifications from OpenHab2, but it’s on my list :wink:


#97

Hi Jeroen,

Do you mean support for the vmb1tc or vmb1ts? It seems like the vmb1ts is quite similar to the vmbgpo, so I think it shouldn’t be to difficult to support it. If you mean the vmb1tc, which kind of commands for this module would you like to use in openHAB?


#98

you 're right, it’s idd the vmb1ts I meant :wink: . They don’t differ that much idd.


#99

i am using both sitemap and habpanel.
but i found my self using 2 groups : displaying all 18 shutters and displaying all 40 lights.
it is easier for me instead of navigating floors…


#100

hello I would like to use the latest snapshot of cedric but i find the eclipse setup to complicated but a jar file addon would be nice. I would really apreciated.