Velbus House automation, 4 channel RF receiver for Velbus


I’ve got some problems with the 4 channel RF receiver (VMB4RF) and the 4 channel RF transmitter (VMB4TX).
When i connect the receiver on the Velbus-cable (BUS-cable) the receiver seems to get power from the power supply (The power LED is lighting up). My program written trough the Velbuslink software seems alright and i used a simple program to test it. It’s kinda like when the transmitter’s channel 1 button is pressed, the channel oneof the 4 channel relay module needs to close. But when i try to use the transmitter, the receiver seems not to get any signal from it. Even when if i try to use the manual button on the module itself, the Tx-LED and Rx-LED are lighting up but the relay channel doesn’t close.

I don’t know what i’m doing wrong … All the help i welcome :wink:

Thanks you in advance,

The ‘manual’-button will not turn on the relay. When pressed, it puts an ID on the bus, so that Velbuslink can discover the unit.
Did you put the receiver in learn mode and did you successfully ‘learn’ the transmitter to the receiver?
If not, the receiver will not react to the transmitter.

Thanks VEL417 for replying :wink:

I think i did put the receiver on learn mode and connected the transmitter with the receiver … but i’ll try it again, maybe then the problem gets solved ( I hope so xD). But thanks anyway!! :wink:


Could you tell me how to link the emitter with the receiver?
I cant find any information on how to get the “learn mode”

Thx a lot

Connect to your installation with VelbusLink. Open the ‘Transmitters’ tab in the configuration dialog of the VMB4RY. Press the Learning Mode button and follow instructions.

But the vmb4ry doesnt have a configuration dialog(it’s grey), and on the vmb4rf configuration dialog i can just edit the response time of channels.

I’m sorry, I meant the configuration dialog of the VMB4RF. If you do not see the ‘Transmitters’ tab, put a checkmark in the ‘Show advanced features’ checkbox in the bottom left corner of the dialog.

Ok it’s working now, i didnt see the small checkbox. Thx for your fast replies. I just still have one question : is this possible to use the macro fonctions with the emitter, cause they are grey too?

All On and All Off can only be applied to regular pushbuttons, but we will try to add this in a new version.

i got another issue with the rf system.
This is quite strange, i will try to explain it simply.
To make it work i have to do a first impultion with the emitter at max 2cm of the receiver, and then it works for a period of ten minutes. During these ten minutes i can use properly the emitter at a distance of 30 meters without problem. But after theses 10 minutes, i have to use again the emitter at max 2cm of the receiver to make it work again.

I tested with 3 different emitters and new batteries


If have same problem with range after some time.
Any news about this problem or we can i solve this


Hey guys come on

no idea about this problem

following things i have done

fw update
but it out of the frame
resett to factory
plug of from power

all these only tmp solutions

at irregular intervals i had to “wake up the receiver” the transmitter must be very close to the receiver (round about 2cm) after that the receiver works temporarily normal with a range about 20-30 m


Check if the antenne on the receiver VMB4RF makes good connection on the pcb. Maybe you can resolder it.

Logiquement pas grave, puisqu’elle s’allume déjà automatiquement au couché du soleil, et s’etteind à 23h00.
Donc ca ne devrait pas poser de soucis.

[quote=“eshall”]Logiquement pas grave, puisqu’elle s’allume déjà automatiquement au couché du soleil, et s’etteind à 23h00.
Donc ca ne devrait pas poser de soucis.[/quote]

sorry english only or german thx

good answer the antenne was not really soldered but my joy did not last long after one day and one night
at afternoon today same problem as befor

so please help

Good RF reception can be tricky.
In order to check if the problem is related to the receiver or the location, please test the unit in a different location (you can connect it anywhere to the Velbus system). Should the problem persist, then please return the unit for inspection/ repair/exchange.

i have tried serveral positions in my house without no success.
so i´ve put out my radio and tv mechanic school book to read about antenna so i´ve changed the the antenna, and juhu it works now for 7 days


Can you supply more info regarding the modifications that you have done?


in short i´ve replaced changed the antenna

The long way
i´ve taken my radio and tv school book from my younger days to refresh the antenna technology
then i did some reverse engineering with a spektrum analyzer,oscilloscope and a stupid multimeter.
After some measurements i found out that the original antenna brings not enough power to wake up the device, so the only one thing todo was a “bigger” antenna “35cm wire = lamda 1/2”.
With these moods i get now enough voltage from the dipol so that the device is comming up, now it runs without any problem the last three weeks and i will hope for a long time.
The only thing is i cannot say if the input "voltage"from the antenna isnt to high so that the 433 modul dies sometimes.



who gets the request for the extented warranty i´ve got no responce since a month. My home got a complete velbus automation with over 6ts € so please be nice to me.


We’ll check about the extended warranty.
Stay tuned…